鱒身(Masu_mi)のブログ

知った事をメモする場所。

OSXでComposerを導入した

OSXでcomposer 導入した際に引っかかった内容をメモしておく。composer はJSONでコンポーネントを管理するツール。

起きた事

  1. homebrewComposer をインストールしようとすると PHP53, PHP54 , PHP55 のどれかを brew でインストールする事を要求される。
  2. PHP55 のビルドで失敗

原因

Command Line Tools がOS Updateで無くなっていた。昔と違い Xcode からインストール出来なくなっていた。

解決した手順

以下を素直に叩く。 xcode-selectXcode のバージョンを切り替えるのに使うらしい。

$ # xcode-selec
$ xcode-select --install
$ brew install php55
$ brew install composer