鱒身(Masu_mi)のブログ

知った事をメモする場所。

easy_installのpkgをまとめてupdateした

Marvericks にアップデートしたら virtualenv がエラーを吐くようになった。 とりあえずインストールしたのは easy_install だったので easy_install 経由で入れているパッケージ群を全てアップデートした。 そしたら解消された。ラッキーである。技術者としてはあまり勧められない態度だけど、どう解決していいかアプローチが見えなかった。

easy_install -U `python -c "for dist in __import__('pkg_resources').working_set: print dist.project_name"`

アプローチにちては今後考えるにして、これでMarvericksにアップデートした後の問題は gcc, ghcVirtualBox のバージョン確認機能に絞られた。